Debian – flash 11.2.202.228 dla i386 zepsuty.

Jeśli ktoś posiada Debiana w wersji 32bit (architektura i386) i korzysta z niewolnego pluginu flash (pakiet flashplugin-nonfree), to niech uważa z aktualizacją flasha do wersji 11.2.202.228. Wygląda, ze jest bug i po aktualizacji do ww. wersji flash przestaje działać i to we wszystkich przeglądarkach (sprawdzone w Iceweasel, Opera, Chromium). Problem objawia się tak, że sam plugin jest widoczny w przeglądarce, ale po prostu obiekty flash nie są uruchamiane.

Sprawdzone na 2 niezależnych systemach, z czego jeden to praktycznie czysty Squeeze, a drugi „mieszaniec” (Squeeze + backports + unstable). Pierwotnie podejrzewałem kombinację Iceweasel 11 + upgrade flash, ale nie o to chodzi. No i z kanału #debian wiem, że nie jestem jedyną ofiarą błędu.

PS Dla architektury amd64 błąd nie występuje – wszystko działa poprawnie, można spokojnie aktualizować. Jak będę znał rozwiązanie, to pojawi się aktualizacja.

UPDATE: Z tego co widzę w sieci, problem dotyczy wszystkich dystrybucji Linuksa i tylko architektury i386: https://bugbase.adobe.com/index.cfm?event=bug&id=3154276 https://bugbase.adobe.com/index.cfm?event=bug&id=3161034 http://forums.gentoo.org/viewtopic-t-918560-postdays-0-postorder-asc-start-0.html Adobe nie spieszy się do naprawy, jako, że plugin dla Linuksa oficjalnie nie jest wspierany. W którymś wątku pojawiła się sugestia, że wyłączenie akceleracji video rozwiązuje problem (nie weryfikowałem).

UPDATE: Widzę w pytaniach do wyszukiwarki pytanie o alternatywy dla flash, więc dla porządku: jest GNU Gnash, który działa średnio, że tak to ujmę (mało wydajny przede wszystkim z tych paru chwil, kiedy korzystałem) i jest Lightspark, z którym zupełnie nie miałem styczności, a który może być bardziej wydajny, bo przepisany od zera z myślą o wydajności na współczesnym sprzęcie.

UPDATE: Wygląda, że bug występuje tylko na procesorach bez SSE2 (grep –color sse2 /proc/cpuinfo aby sprawdzić, czy procesor ma obsługę SSE2), czyli głównie Athlon i okolice a Adobe nie kwapi się z wypuszczeniem wersji skompilowanej bez tego zestawu instrukcji. Ostatecznie zostaję z Gnash.

UPDATE: 2012.08.12 – Dochodziły mnie słuchy, że na oryginalnym Chrome od Google jest inny Flash, więc sprawdziłem zarówno stable 21.0.1180.75, jak i betę 22.0.1229.2. Nie działa na żadnym.

2 odpowiedzi do “Debian – flash 11.2.202.228 dla i386 zepsuty.”

  1. Flash dla Linuksa działa jedynie dobrze w Google Chrome. Jeśli ktoś chce korzystać z Flasha na innej przeglądarce musi po prostu skopiować plugin z katalogu Google Chrome (/opt/google/chrome) do katalogu pluginów swojej przeglądarki.

  2. @seba: U mnie nie działał również na Chromium z tego co pamiętam – wygląda, jakby korzystało z systemowego. Być może różnica Chromium vs. Chrome…
    BTW możesz podać linka do źródła tej wiadomości? Na pewno na Debianie jest inna ścieżka – w /opt jest pusto.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *