Rowery miejskie – zabezpieczenia.

Rowery miejskie Poznań

Źródło: fot. własna.

Niedawno dowiedziałem się, że znajomy ma konto do wypożyczania rowerów miejskich w Poznaniu. Porozmawialiśmy trochę, ponarzekaliśmy trochę na procedury (np. konieczność posiadania minimum 10 zł na koncie, żeby cokolwiek wypożyczyć) i doszliśmy do momentu, kiedy stwierdziłem, że chętnie bym się przejechał rowerem, choć bez upierdliwego zakładania konta. No i okazało się, że dodatkowo nie da się bez telefonu, bo na telefon jest przysyłany kod do zapięcia. A już miałem nadzieję, że wystarczy PIN do systemu pamiętać, bo przecież chyba jest budka z terminalem…

Co sprowokowało do zastanowienia się nad tematem jakby tu obejść te głupie wymagania. No i wyszło mi, że praktycznie zabezpieczenia są żadne, bo albo zabezpieczenie z kodem jest przywiązane do stacji, albo do roweru (z tego co wiem, to drugi wariant). Czyli każdy, kto wypożyczył dany rower zna do kod do jego zapięcia. Przynajmniej przez jakiś czas (zakładam, że co jakiś czas kody są zmieniane, choć pewnie niezbyt często, bo wygląda to na dość skomplikowaną akcję).

Zresztą na kradzież roweru miejskiego nie trzeba było długo czekać. Jako główne zabezpieczenie w artykule wymieniany jest – słusznie – charakterystyczny wygląd roweru. Zastanawiam się, czy mógłby w takim razie zadziałać system oparty na dobrowolnych opłatach: charakterystyczne rowery, można je wziąć i zostawić w dowolnym miejscu, płatność podobnie jak dotychczas, czyli prepaid. Oczywiście wiem, że coś podobnego było kiedyś w Amsterdamie (tyle, że bez opłat) i wtedy nie wyszło. Teraz można by dorzucić trochę techniki i wyposażyć rower w GPS i modem do przesyłania pozycji (prąd by się znalazł, skoro rower jeździ), żeby można je było odnaleźć, gdy ktoś odstawi w dziwnym miejscu. Tylko czy GPS i modemu nie ukradną? :-/

Koniec grup news (NNTP) w Polsce?

Dawno, dawno temu, w czasach, gdy Internet nosiło się w wiaderkach[1] i kosztowało to sporo, korzystałem z grup news. Obok WWW i email była to główna forma aktywności w Internecie, perwersje typu portale społecznościowe, blogi i µblogi zwyczajnie nie istniały. Nawet mam skonfigurowany czytnik news (XPN), który powiedzmy, że daje radę. Ale newsy umarły, na rzecz innych form komunikacji. Ludzie przenieśli się na ww. formy platformy (tak, naprawdę sporą część ludzi widzianych na blogach i µblogach kojarzę z news)…

Dziś na IRC (który jakoś tam nadal żyje) padło pytanie czy subskrybuje ktoś z was newsy, bo coś dziwnego mi się dzieje. Do subskrybcji średnio się poczuwam (raz na parę tygodni odpalę czytnik, od dawna nic nie piszę), ale postanowiłem zerknąć, bo w sumie mój klimat. Otóż nie wysyłają się posty przez serwery news.onet.pl i news.gazeta.pl. Klik, klik, telnet na 119 – nic. Ping – nic. Wejście na niusy.onet.pl i wszystko jasne. Potem poczytałem pl.news.admin i poza ww. serwerami wyłączony został jeszcze news.lublin.pl. Ale bolą głównie te dwa, były chyba najpopularniejszą metodą wysyłania postów dostępną za darmo i dla wszystkich (po zalogowaniu), bez względu na ISP. 

Tak, wiem, to jeszcze temat z zeszłego roku, ale dopiero teraz się dowiedziałem. Co też o czymś świadczy.

[1] Serio. Były narzędzia do ściągania news w jednym miejscu i przenoszenia do komputera, na którym się je czytało. Albo narzędzia pozwalające na pobranie skompresowanych (i IIRC przefiltrowanych) postów. I płaciło się za każdą minutę/sekundę połączenia, nie za ilość pobranych danych. Potem TPSA (obecnie działająca pod marką Orange – kolejny znak czasów) wprowadziła pakiety i w końcu stałe łącza do domu.

UPDATE: Wygląda, że pogłoski o wyłączeniu news.gazeta.pl były przesadzone. Faktycznie przed chwilą nie odpowiadał, ale teraz:

200 news.gazeta.pl InterNetNews NNRP server INN 2.3.5 ready (posting ok).

Poznański rower miejski moim okiem.

Rowery miejskie Poznań

Źródło: fot. własna.

Dziś niemal skorzystałem z usług Poznańskiego roweru miejskiego, czyli nextbike.pl. Czemu prawie? Otóż tak wyszło, że wylądowałem na przystanku, przy którym znajduje się stacja niedawno uruchomionej wypożyczalni rowerów i czekałem na tramwaj. Spojrzałem na rowery i skojarzyłem, że tam, dokąd jadę, także jest stacja rowerów. Skoro nie ma tramwaju, to po co czekać, skoro można wziąć rower i przejechać? Tym bardziej, że kojarzyłem, że pewien okres czasu jest za darmo, a napis zachęcał zadzwoń i jedź.

Skoro to takie proste, to postanowiłem przetestować usługę i zadzwoniłem. Oczywiście z komórki. IVR był jakiś powolny – długie pauzy itp., a menu nie znałem, bo pierwszy raz dzwoniłem. W końcu dotarłem do momentu, gdzie powinien zgłosić się konsultant i… czekałem. I czekałem. I zdążył pojawić się w zasięgu wzroku mój tramwaj, więc dałem sobie spokój, tym bardziej, że mam sieciówkę. To byłby w zasadzie koniec historii, ale…

W domu wszedłem na stronę i okazało się, że dobrze, że się nie doczekałem, bo nic by z tego nie było i tak. Trzeba się zarejestrować wcześniej, wpłacić pieniądze i dopiero wtedy można korzystać. Rozmieszczenie wypożyczalni i cennik też nie zachęcają (przynajmniej mnie). Wypożyczalnie są raczej blisko siebie i raczej w mało ważnych/atrakcyjnych miejscach (może poza Starym Browarem i dworcem PKP). Pierwsze 20 min gratis – OK i miłe (szczególnie, że dzwoniąc i tak ponosi się jakiś koszt). Kolejne 40 minut za 2 zł – OK. Każda następna godzina 4 zł – WTF?! Progresywny, zniechęcający do dłuższego korzystania cennik?

Regulamin też nie jest ani specjalnie jasny, ani prosty, ani spójny. Choćby 50. Opłaty na poczet wypożyczeni (kwota doładowania) nie podlegają zwrotowi w połączeniu z Opłata inicjalna (zwrotna) – minimalny stan konta 10 zł ze strony ZTM oraz wpłać minimum 1 pln opłaty inicjacyjnej ze strony nextbike.pl. To w końcu 10 zł czy 1 zł? I zwrotne czy bezzwrotne? Tabela opłat na stronie nextbike zawiera pozycje nie występujące w regulaminie (powiadomienia SMS, telefoniczne, listowne). No i 2 zł za SMS, który może być wysłany… no właśnie nie wiadomo kiedy, to trochę sporo.

W każdym razie pomysł może i fajny, ale wykonanie zniechęcające, przynajmniej dla mnie. Chyba nie tylko dla mnie, bo stojaki są cały czas pełne rowerów. No i pytanie, czemu skoro ZTM bierze w tym udział, to czemu nie ma wsparcia dla komkarty i nie ma zniżek dla jej posiadaczy?

Rockbox 3.11.2

O Rockbox 3.11 nie napisałem nic, bo wcześniej napisali inni w polskiej sieci, a i dopiero niedawno go wgrałem na moje urządzenie, bo wielkich zmian (dla mnie) nie było, więc donoszę o wersji 3.11.2, która zawiera wyłącznie poprawki błędów, w tym naprawia radio dla Sansa e200 i c200. Czyli dla mojego playera. Nie żebym z radia korzystał… 😉 Tradycyjnie pełna lista zmian dla Rockbox 3.11.2.

Debian – flash 11.2.202.228 dla i386 zepsuty.

Jeśli ktoś posiada Debiana w wersji 32bit (architektura i386) i korzysta z niewolnego pluginu flash (pakiet flashplugin-nonfree), to niech uważa z aktualizacją flasha do wersji 11.2.202.228. Wygląda, ze jest bug i po aktualizacji do ww. wersji flash przestaje działać i to we wszystkich przeglądarkach (sprawdzone w Iceweasel, Opera, Chromium). Problem objawia się tak, że sam plugin jest widoczny w przeglądarce, ale po prostu obiekty flash nie są uruchamiane.

Sprawdzone na 2 niezależnych systemach, z czego jeden to praktycznie czysty Squeeze, a drugi „mieszaniec” (Squeeze + backports + unstable). Pierwotnie podejrzewałem kombinację Iceweasel 11 + upgrade flash, ale nie o to chodzi. No i z kanału #debian wiem, że nie jestem jedyną ofiarą błędu.

PS Dla architektury amd64 błąd nie występuje – wszystko działa poprawnie, można spokojnie aktualizować. Jak będę znał rozwiązanie, to pojawi się aktualizacja.

UPDATE: Z tego co widzę w sieci, problem dotyczy wszystkich dystrybucji Linuksa i tylko architektury i386: https://bugbase.adobe.com/index.cfm?event=bug&id=3154276 https://bugbase.adobe.com/index.cfm?event=bug&id=3161034 http://forums.gentoo.org/viewtopic-t-918560-postdays-0-postorder-asc-start-0.html Adobe nie spieszy się do naprawy, jako, że plugin dla Linuksa oficjalnie nie jest wspierany. W którymś wątku pojawiła się sugestia, że wyłączenie akceleracji video rozwiązuje problem (nie weryfikowałem).

UPDATE: Widzę w pytaniach do wyszukiwarki pytanie o alternatywy dla flash, więc dla porządku: jest GNU Gnash, który działa średnio, że tak to ujmę (mało wydajny przede wszystkim z tych paru chwil, kiedy korzystałem) i jest Lightspark, z którym zupełnie nie miałem styczności, a który może być bardziej wydajny, bo przepisany od zera z myślą o wydajności na współczesnym sprzęcie.

UPDATE: Wygląda, że bug występuje tylko na procesorach bez SSE2 (grep –color sse2 /proc/cpuinfo aby sprawdzić, czy procesor ma obsługę SSE2), czyli głównie Athlon i okolice a Adobe nie kwapi się z wypuszczeniem wersji skompilowanej bez tego zestawu instrukcji. Ostatecznie zostaję z Gnash.

UPDATE: 2012.08.12 – Dochodziły mnie słuchy, że na oryginalnym Chrome od Google jest inny Flash, więc sprawdziłem zarówno stable 21.0.1180.75, jak i betę 22.0.1229.2. Nie działa na żadnym.

Nowy laptop.

Dell 1440

Źródło zdjęcia (i recenzja, co prawda trochę inny model, bez grafiki AMD, ale reszta się zgadza): http://www.laptopreviews.com/dell-vostro-1440-review-2011-12

W końcu, po latach kupiłem sobie laptopa. Ostatnio jakoś cały czas korzystałem albo ze służbowego, albo z różnych starych. Nie da się ukryć, że stary laptop spisywał się dobrze do zadań podstawowych, ale… tłumaczenie dla FSF z użyciem virtaal było ciut mało komfortowe, a zupełnie irytujące, gdy dorzuciłem do tego muzykę z YT. Zresztą YT ogólnie średnio działało, przynajmniej w przeglądarce. Bo z użyciem minitube to i owszem, ale jednak znowu – nie ten komfort. Tak więc po dwóch latach przyszła pora na zakup.

Po krótkim wyszukiwaniu w porównywarkach cen stanęło na Dellu Vostro 1440. Czemu tak? Matowy ekran (czemu, ach czemu nie ma tego do wyboru jako kryterium w żadnej porównywarce?!), jest mniejszy niż 15″ (tu miałem dylemat – albo 17″ i całkiem stacjonarnie, albo jednak trochę z zachowaniem mobilności – wybrałem to drugie rozwiązanie). Dużo – szczególnie jak na moje standardy – RAM, duży dysk. Chwilę wahałem się, czy wybrać wersję ze znienawidzoną kartą ATI (obecnie AMD), czy Intel. Ostatecznie stwierdziłem, że ATI gorzej tj. wolniej od Intela działać nie powinien, nawet na otwartych sterownikach, więc wziąłem tę z AMD. No i była wersja bez systemu. Znaczy z Linuksem.

No właśnie, laptop przyszedł z zainstalowanym Ubuntu (IIRC 10.10), które zrobiło naprawdę rewelacyjne wrażenie na pierwszy rzut oka – wszystko działa: i wifi, i grafika, i dźwięk, i hibernacja. I wyglądało całkiem elegancko. Przeszła mi myśl, czy nie zostawić tego systemu. Niestety, po bliższych oględzinach i próbie aktualizacji wyszły wady: synaptic zawiesił się na aktualizacji pythona (czy też jego modułów), program do testowania systemu uruchomiony w międzyczasie zawiesił się na sztywno, gdy odmówiłem mu podania hasła do roota i żadną miarą nie dawał się w cywilizowany sposób wyłączyć. W niecywilizowany (kill z konsoli) też nie, bo nie mogłem skorelować nazwy procesu z tymże programem. Czarę goryczy przepełnił Firefox w wersji 3.6 oraz zainstalowany Skype (i pewnie masa innego non-free syfu). Stwierdziłem, że mam gdzieś taki system, nad którym nie panuję, nagrałem płytę rescue na wszelki wypadek i zabrałem się za instalację Debiana przy pomocy debootstrap (stąd m.in. tamten wpis).

Sam zakup też nie jest trywialny w naszym pięknym kraju. Pierwszy sklep, po potwierdzeniu dostępności towaru, wymaganej obowiązkowej rejestracji (nie lubię) i złożeniu zamówienia skontaktował się… w celu poinformowania, że nie obsługują osób fizycznych, wyłącznie firmy i instytucje. Nie rozumiem idei takiego postępowania (przychodzi mi jedynie na myśl chęć uniknięcia 10 dni na zwrot towaru przy zakupie zdalnym), ale drugi sklep, z ceną o kilka zł wyższą nie miał takiego problemu. Warto jedynie odnotować, że w sumie zakup zajął mi tydzień.

Po dość długiej synchronizacji danych (uroki karty wifi bez anteny w starym laptopie, kabla nie chciało mi się szukać…) system w zasadzie działał. Istnieje parę przyjemniejszych rzeczy, niż migracja z 32 bit na 64 bit – chodzi o parę pakietów, którym zmieniają się nazwy i całkiem sporo pakietów (w tym Bloxer2), które nie są popaczkowane, a które trzeba było przeinstalować na wersję 64 bit, ale ostatecznie wszystko działało OK. Sprzęt działa praktycznie od kopa na kernelu 3.2.x , włączając wifi i hibernację (po konfiguracji, którą musiałem sobie odświeżyć). Akceleracja 3D w karcie AMD też działała po instalacji fglrx, ale stabilność pozostawiała nieco do życzenia. Znaczy raz się zwiesił (ale podczas gry w Nerdquiz!), więc fglrx poszły w odstawkę. Na chwilę, bo później do nich wróciłem i było OK.

Żeby nie było za fajnie – przy lspci okazało się, że laptop ma dwie karty graficzne. Wspomnianą AMD oraz… zintegrowanego Intela. Co ciekawe, domyślnie korzysta ze zintegrowanego Intela. I działa to całkiem wystarczająco – YT jest płynne. Tym bardziej wystarczająco, że zabawa z vgaswitcheroo to jakaś masakra i rzeźba. I nie działa. I są zwisy (podobnie, jak przy fglrx). Dowiedziałem się też, że kernele serii rt w ogóle z fglrx nie działają. A sterowanie prędkością wiatraka to zupełna abstrakcja. Niby i8kfan pozwala na coś, ale to coś działa po chwili mocno losowo i zupełnie niezgodnie z konfigiem. Nie wiem, czy ACPI się wdaje w paradę czy o co chodzi, ale ustawienie do którego przywykłem korzystając ze starego laptopa, czyli totalna cisza, a w okolicy bliskiej gotowania totalne wycie chwilowo wydaje mi się nieosiągalne. Przy okazji – osiągnięcie temperatury bliskiej gotowania nie było tam takie proste… Być może chodzi o kartę graficzną? W każdym razie będzie nad czym posiedzieć.

Z innych wad: spacja jest przesunięta trochę w prawo, co powoduje, że odruchowo naciskałem spację, zamiast prawego alt przy pisaniu pl-znaków. Na szczęście przesunięcie jest minimalne, a trochę głębsze podwijanie kciuka weszło mi już w krew. Dokładniejszy opis jak działa Debian na tym sprzęcie pewnie pojawi się za jakiś czas. Generalnie wygląda całkiem dobrze. No i skoro mam sprawną baterię, to mogę korzystać bardziej mobilnie. Ale jeszcze się nie przestawiłem mentalnie i nadal klikam przy biurku.