Nowy router (TP-Link Archer C50)

Poprzedni router wytrzymał cztery lata. Jakiś czas temu zaczął się wieszać – 50% strat pakietów po WiFi, pomagał restart prądowy. Nie było to może bardzo częste, ale na tyle drażniło, że dopisałem nawet codzienny reboot w cronie. Co zmniejszyło problem, ale go nie rozwiązało. I w ogóle problem jakby się nasilał. Od strony systemu (OpenWrt) nic ciekawego w logach, przełożenie w chłodniejsze miejsce, tj. zdjęcie z modemu kablowe jakby trochę pomogło, więc podejrzewam albo przegrzewanie się, albo wysychający kondensator. Tylko nie pasuje mi do tej teorii reset rozwiązujący problem na losowy okres czasu.

Teoretycznie nic, z czym nie mógłbym powalczyć, ale… trochę szkoda czasu. No i są inne powody. Po pierwsze, poprzedni router już się zwrócił. Po drugie jest to wspaniały pretekst do wymiany sprzętu na coś z 5 GHz, bo na 2,4 GHz od dawna robi się tłoczno, a coraz więcej sprzętów obsługuje 5 GHz. Wreszcie zajrzałem na stronę OpenWrt i tam wszędzie warningi, że sprzęty z 4 MB flash lub 32 MB RAM przestają być wspierane. Swoją drogą, może właśnie to była przyczyna niestabilności? Szczególnie, że trochę przeładowany softem i ogólnie na krawędzi był, zdecydowanie wbrew zaleceniom, jak je teraz czytam.

Tak czy inaczej, kupiłem sprzęt. Wybór był nieco skomplikowany, choć wymagania miałem proste: 8 MB flash, 64 MB RAM, wsparcie dla 5 GHz i 802.11ac i oczywiście wsparcie przez OpenWrt. Szybko ustaliłem, że jednym z tańszych urządzeń dostępnych w Polsce spełniających kryteria jest TP-Link Archer C50. Jednak żeby nie było zbyt prosto, okazało się, że wsparcie jest zależne od wersji hardware. Ogólnie nie rozumiem tej mody wśród producentów, żeby robić wiele różnych urządzeń z tą samą nazwą. Wersja hardware spokojnie mogła by być ujęta w nazwie, przynajmniej klient od razu wiedziałby, co kupuje.

Wyszło mi, że potrzebuję albo v3, albo v4. Przy czym sprzęt jest w zasadzie ten sam, a główny problem jest z formatem obrazu – prawdopodobnie v4 nie dorobi się „klikalnej” wersji obrazu na stronie i trzeba będzie się bawić w samodzielne składanie obrazu. Nie jest to jednak coś, co spędza mi sen z powiek.

Na Allegro nie jest łatwo ustalić wersję hardware. Mało który sprzedawca chwali się wprost. Zadałem pytanie o wersję chyba czterem albo pięciu, odpisał jeden. I kupiłbym tam, gdyby nie fakt, że zdążył zakończyć sprzedaż. Chociaż w sklepie na stronie nadal były dostępne. Ostatecznie kupiłem u innego sprzedawcy kota w worku. Kot okazał się być v4.

Tradycyjnie nie przechodziłem na OpenWrt od razu, tylko dałem szansę firmware’owi producenta. Okazało się, że wgrany jest najnowszy dostępny. Tradycyjnie dostępnych wiele opcji konfiguracyjnych. Można nawet wybrać z GUI cykliczny reboot, czego nie było w poprzednich wersjach. Można zdefiniować tryb nocny, kiedy diody mają być wyłączone i ustalić – niezależnie – moc każdej z kart sieciowych (low-medium-high). Wygląda to naprawdę przyzwoicie. Dwa zakresy oznaczają de facto dwa niezależne interfejsy sieciowe i prawdopodobnie dwie oddzielne karty z dwiema antenami każda. Obie sieci ustawiłem na średnią moc.

Ogólnie po trzech tygodniach korzystania jestem zadowolony. Na razie zostaje firmware producenta. Jak na sprzęt za 110 zł działa bardzo fajnie i stabilnie. Tam gdzie to możliwe korzystam z 5 GHz. Pokazuje niby słabszy sygnał, niż na 2,4 GHz ale działa bardzo dobrze i speedtest na luzie, powtarzalnie, pokazuje zarówno maksymalny upload, jak i download w stosunku do tego co oferuje ISP.

Testy szybkości sieci wewnętrznej i pomiary poboru prądu – jak mi się przypomni.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *